搜索

CentOS运行Django时提示出错:SQLite 3.8.3 or later is required (found 3.7.17),出现这种错误主要是因为SQLite版本太低的原因。我们升级一下SQLite的版本就好。 升级步骤如下: 去SQLite官网: https://www.sqlite.org/download.html 找到最新版本的tar.gz包下载下来。 如:

#下载
wget https://www.sqlite.org/2020/sqlite-autoconf-3310100.tar.gz
# 编译
tar zxvf sqlite-autoconf-3310100.tar.gz

cd sqlite-autoconf-3310100

./configure --prefix=/usr/local

make && make install
# 替换系统低版本 sqlite3
mv /usr/bin/sqlite3  /usr/bin/sqlite3_old

ln -s /usr/local/bin/sqlite3   /usr/bin/sqlite3

echo "/usr/local/lib" > /etc/ld.so.conf.d/sqlite3.conf

ldconfig

sqlite3 -version

升级成功之后,就能正常运行!

python3 manage.py runserver

Django

版权属于:guoxiaorui
作品采用:本作品采用 知识共享署名-相同方式共享 4.0 国际许可协议 进行许可。
0
查看目录

目录

来自 《Django运行提示:SQLite 3.8.3 or later is required (found 3.7.17)》
评论

guoxiaorui

人性的不耐和懒惰,是人们陷入贫穷的基本原因~
© 2021 程序猿小睿